System Update 9.3.0-21 Now Available On 3DS

Door Arturotillo gepubliceerd op Tuesday 09 December 03:20

Now, Nintendo’s latest system update for the 3DS has arrived, it is version 9.3.0-21. The 3DS 9.3.0-21J was first released. It is said that 9.3.0-21J blocked all flashcart including the gateway 3ds. However, after testing on the 9.3.0-21U, all r4 3ds card can work on the 9.3.0-21U directly. That's to say all main flashcards can work on the latest version smoothly, here is the details for your reference:


Here is the flashcards list which can support 3DS 9.3.0-21U:

    1.Wood R4i Gold 3DS (Reasonable price, always update quick)
    2.Supercard DSTWO (the most famous and welcomed slot-1 flashcard, never blocked by Nintendo updates since it born. With powerful CPU support and built-in GBA/SNES emulator)
    3.R4i-sdhc 3DS RTS (Support RTS )
    4.Ace 3DS  Plus (Has bottom price and strong function)
    5.R4i SDHC Dual Core
    6.R4i SDHC RTS
    7.R4i-Gold Pro

Working 3ds flashcarts:

    Sky3ds and r5sdhc card.

For gateway 3ds card users, still no news about the new firmware for 9.2.0-20, so we cannot test it on the 9.3.0-21. So don't upgrate your 3ds to 9.3.0-21 if you want to use the gateway 3ds card.

 

 

Reacties (0) 

Voordat je kunt reageren moet je aangemeld zijn. Login of maak een gratis account aan.